思科交换机基本配置实例讲解,思科模拟器上进

1、基本概念介绍

       IOS:       互联网操作系统,也正是沟通机和路由器中用的操作系统

       VLAN:    虚拟lan

       VTP:       VLAN TRUNK PROTOCOL

       DHCP:    动态主机配置合同

       ACL:    访问调整列表

       三层交流机:具有三层路由转载技艺的调换机

本课程中“#”后的朱红文字为注释内容。

 

开垦Packet Tracer,选中”交换机“,拖动调换机列表的交换机,这里以2960-24TT为例。

2、密码、登录等骨干配备

本节介绍的原委为cisco路由器恐怕调换机的基本配备,在现阶段版本的cisco交流机或路由器上的那几个命令是通用的。本教程用的是cisco的模拟器做的牵线,一些切实可行的端口展现或者与你们其实的装备不符,但那并不影响基本配备命令的实行。

Cisco 3640 (R4700) processor (revision 0xFF) with 124928K/6144K bytes of memory.

Processor board ID 00000000

R4700 CPU at 100MHz, Implementation 33, Rev 1.2

2 Ethernet interfaces

8 Serial interfaces

DRAM configuration is 64 bits wide with parity enabled.

125K bytes of NVRAM.

8192K bytes of processor board System flash (Read/Write)

         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: n  

 

# 此处大家选用no,不进去她的开首化配置向导

 

Press RETURN to get started!      

# 选用no未来,提醒您按回车键开头,此处大家要求按回车键

 

*Mar  1 00:43:56.591: %IP-5-WEBINST_KILL: Terminating DNS process

*Mar  1 00:43:58.379: %SYS-5-RESTART: System restarted --

Cisco IOS Software, 3600 Software (C3640-JK9O3S-M), Version 12.3(14)T7, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Wed 22-Mar-06 21:46 by pwade

*Mar  1 00:43:58.411: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start

 

Router>         

# 等显得稳固后,出现最早的唤起符,注意提示符是“>”,最近所处的图景称为客户方式。

Router>

Router>en     

# 要是在时下意况下并未有重新的通令,我们可以用“TAB”键来补齐这条命令,重要指标是为了有助于阅读

Router>enable      

# 从客户方式(user mode)步入到特权格局(exec mode),注意提示符的浮动,提示符变为“#”

Router#conf t 

Router#configure terminal

(说明:#在特权格局下输入configure terminal步向全局配置情势(global configuration mode),在这之下输入的通令叫做全局命令,一旦输入,将对全数router发生即时影响。如下,注意提醒符的成形:)

Router(config)#exit                     # 请注意提示符发生了改变,当前的格局据称为全局配置形式。

Router#conf

*Mar  1 00:44:26.491: %SYS-5-CONFIG_I: Configured from console by console t      # 在输入指令的进度中,IOS会油然则生有的即时提示。

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#exit                     # 退出当前的全局配置格局的通令是exit

Router#conf t                       # 重新步向到全局配置格局

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#

*Mar  1 00:44:35.591: %SYS-5-CONFIG_I: Configured from console by consolehos   

# 那行是路由器(交流机)出现的一对即时提示。

Router(config)#hostname test      

# 那条命令用来改造当前器材的名字(名字中可含蓄设备的楼层、用途等信息),首假使为着后天有利区分设备。

test(config)#                

# 回车的前边大家就能够发觉,但前的装置的名字曾经发生了转移,形成了test了。

test(config)#enable pass

# 那条命令用来布局设施的登入密码,用tab键补齐后,再下一行显示完整命令。

test(config)#enable password cisco      # 大家输入那台器材的登录密码为 cisco

test(config)#end                                 # 大家退回到全局配置情势,校验一下刚刚输入的密码

test#sh r 

# 此命令的一体化写法是show running-start,此处的sh r用的是简约的写法,因无任何重复的命令所以能够被实行。

Building configuration...
Current configuration : 1559 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname test                # 注意此处显示的是我们配置的设备的名字
!
boot-start-marker
boot-end-marker
!
enable password cisco          
# 此处显示的是刚才我们配置的enable密码,注意此时是用明文显示的,有点不安全。
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!

# 到这一行其实远非全体出示完配置的开始和结果,我们得以开关盘上的率性键来终止继续呈现。在呈现的进度中通过按回车键可以逐行显示,按空格键能够一页一页的展现。那一个操作可在其实的器械中体会。

 

test#conf t                                                       # 重新走入到全局配置情势

 

test(config)#service pass

test(config)#service password-encryption           # 利用那条命令给密码加密展现。

test(config)#end

test#sh r                                                          # 退出到全局配置格局后,验证刚才的配备。

Building configuration...

 

Current configuration : 1565 bytes
!
version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption
!
hostname test
!
boot-start-marker
boot-end-marker
!
enable password 7 070C285F4D06      

# 注意此处刚才明文显示的密码已经变成加密显示了,这样从一定程度上保证了密码的安全。
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
# 验证完毕后按任何一个键中断显示,下面的内容说明终端登陆密码的配置。

 

test#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

test(config)#no service password-encryption

# 可应用这条命令(前边加no)来去掉密码加密功效,cisco的全部命令都能够由此这种艺术来禁绝。

test(config)#line con

test(config)#line console 0            # 利用那条命令来配置用顶尖终端登录时的一些参数。

test(config-line)#pass

test(config-line)#password cisco    # 增添密码,此处大家配备的密码为cisco

test(config-line)#loggi

test(config-line)#logging ?          

# 在别的情状下一旦您忘掉了指令的连锁参数能够用?来得到晋升和帮扶

synchronous  Synchronized message output

test(config-line)#logging sy

test(config-line)#logging synchronous

# 在我们进行布局时,IOS会时有产生局地马上的提醒音信,而那么些新闻会冲乱大家的光标展现,用那条命令能够将光标规矩在下一行,固然出现了有的应声的提示。

test(config-line)#exit                   # 退出当前console口的参数配置

test(config)#line vt?                     #  telnet登录时有关参数的配备,此处用了?来寻求提醒。

 

 <0-134>  First Line number

  aux      Auxiliary line

  console  Primary terminal line

  tty      Terminal controller

  vty      Virtual terminal

  x/y      Slot/Port for Modems

test(config)#line vty 0 4       

# 我们配备设想终端的0到4,也便是同有的时候候允许5个顾客能够telnet到那台器械上来。

test(config-line)#pass

test(config-line)#password cisco   

# 我们配备telnet时的密码为cisco,如果这里大家不设置密码,那么用telnet来登录的时候并不会以空密码登入,而是会给您唤醒说:相关密码没有安装,禁止登入。所以我们为了能远程telnet到那台器械,此处的密码应当要设置好。

test(config-line)#login                 # 那条命令是同意通过telnet来报到

test(config-line)#exit                   # 退出当前安插形式到全局配置形式。

test(config)#

test(config)#

test#conf s            

# 大家在做布署的时候,会出现输入错误的情形,在这种景观下ios会感觉你输入的是四个域名

Translating "s"...domain server (255.255.255.255)     

# 那么ios会做短期的检索,试图找到那些域名对应的ip地址.......

Translating "s"...domain server (255.255.255.255)     

# 这几天是比较长的,那么大家什么禁止使用它的这么些功能吗?

% Unknown command or computer name, or unable to find computer address

test#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

test(config)#no ip domain-lookup        # 在大局配置情势下,将ip域名的探求功能关闭即可了。

test(config)#end

test#conf

*Mar  1 01:40:46.895: %SYS-5-CONFIG_I: Configured from console by console

test#conf x             # 将上述意义关闭之后,再有输入错误的事态会直接提醒您输入错误。

        ^

% Invalid input detected at '^' marker.

 test#

test(config)#ip domain-name 202.102.128.68

# 借使有必不可大校配备配置上DNS效能的话就用那条命令。

 ### 基本配备完成后大家证实一下具备的布署###

test#sh run

Building configuration...
Current configuration : 1693 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption                # 密码加密显示功能打开
!
hostname test
!
boot-start-marker
boot-end-marker
!
enable password 7 070C285F4D06       # 密码被加密显示了
!
no aaa new-model
!
resource policy
!
memory-size iomem 5

ip subnet-zero
!
!
ip cef   

no ip domain lookup                           # 关闭了域名查找功能

no ip dhcp use vrf connected

!
!
no ip ips deny-action ips-interface

!

no ftp-server write-enable

!

no crypto isakmp ccm
!
(略……)

ip http server

no ip http secure-server

ip classless

!        
control-plane
!
line con 0

 exec-timeout 0 0
 password 7 094F471A1A0A       # 用超级终端登陆的密码,也同样被加密显示
 logging synchronous
line aux 0
line vty 0 4
 password 7 00071A150754         # 用telnet登陆的密码,也同样被加密显示
 login
!
!
end

3、cisco设备端口配置详解

 

User Access Verification

# 从dos指示符下运行telnet ip地址,就能接连到对应的交流机也许路由器

 

Password:                     # 输入配置号的telnet密码,也正是上节事关的vtp中的密码

test>en                       # 步向特权形式

Password:                    # 输入特权形式密码,相当于上节事关的enable密码。注意这么些密码在输入的时候显示屏是不展现的。

test#

test#

test#sh ip int brief         # 查看当前具备端口状态,蕴含vlan和实在的物理接口状态

 

Interface              IP-Address      OK? Method Status                Protocol 

# 那行列示的各样情状的名目

FastEthernet1            unassigned      YES NVRAM  down                  down   

Vlan1                  192.168.113.254  YES NVRAM  up                    up

# vlan1的情景是active    

Vlan2                  172.16.0.2       YES NVRAM  up                    up     

Vlan10                 192.168.101.254  YES NVRAM  up                    up     

Vlan20                 192.168.102.254  YES NVRAM  up                    up     

Vlan30                 192.168.103.254  YES NVRAM  up                    up     

Vlan40                 192.168.104.254  YES NVRAM  up                    up     

Vlan50                 192.168.105.254  YES NVRAM  up                    up     

Vlan60                 192.168.106.254  YES NVRAM  up                    up     

Vlan70                 192.168.107.254  YES NVRAM  up                    up     

Vlan80                 192.168.108.254  YES NVRAM  up                    up     

Vlan100                192.168.110.254  YES NVRAM  up                    up     

Vlan110                192.168.111.254  YES NVRAM  up                    up     

Vlan120                192.168.112.254  YES NVRAM  up                    up     

Vlan150                192.168.100.254  YES NVRAM  up                    up     

Vlan160                192.168.115.254  YES NVRAM  up                    up     

GigabitEthernet1/1        unassigned      YES unset     up                    up

 

# 物理接口gi1/1也是active状态    

GigabitEthernet1/2     unassigned      YES unset  down                  down   

GigabitEthernet1/3     unassigned      YES unset  down                  down   

GigabitEthernet1/4     unassigned      YES unset  down                  down   

GigabitEthernet1/5     unassigned      YES unset  down                  down   

GigabitEthernet1/6     unassigned      YES unset  down                  down   

GigabitEthernet1/7     unassigned      YES unset  down                  down    

GigabitEthernet1/8     unassigned      YES unset  down                  down   

GigabitEthernet1/9     unassigned      YES unset  down                  down   

 

# 表明:通过上述命令即能够查阅当前器械具有意况的处境也得以查看端口的意味方法。在此例中大家登入的是一台cisco4503的三层调换机;个中GigabitEthernet1/1,表示的是那台交流机上的第1块业务板的第4个端口,况兼此端口是个千兆端口;而GigabitEthernet3/19意味着的是这台交换机上的第3块专门的工作版的第十八个端口,并且此端口也是一个千兆端口,别的的端口依此类推。千兆端口的名号为:GigabitEthernet,百兆端口的名号为:法斯特Ethernet。

 

test# conf t    

# 进入到全局配置形式。要想对端口、vlan、路由等操作必然要到全局配置方式中来。

Enter configuration commands, one per line.  End with CNTL/Z.

test(config)#inter

test(config)#interface gi1/2          

# 通过此命令可步向端口配置方式,此处我们进去的是GigabitEthernet33.33%口,gi52%为简写。

test(config-if)#?                  

#回车的后边跻身到端口配置格局,注意指示符的转移,输入?寻求在这些格局着这一个的帮忙。

Interface configuration commands:

  access-group            Access group configuration

  arp                     Set arp type (arpa, probe, snap) or timeout

  auto                    Configure Automation

  backup                  Modify backup parameters

  bandwidth               Set bandwidth informational parameter

  bgp-policy              Apply policy propogated by bgp community string

  carrier-delay           Specify delay for interface transitions

  cdp                     CDP interface subcommands

  channel-group           Etherchannel/port bundling configuration

  channel-protocol        Select the channel protocol (LACP, PAgP)

  dampening               Enable event dampening

  default                 Set a command to its defaults

  delay                   Specify interface throughput delay

  description             Interface specific description

  dot1x                   Interface Config Commands for 802.1x

  duplex                  Configure duplex operation.

  exit                    Exit from interface configuration mode

  flow-sampler            Attach flow sampler to the interface

  flowcontrol             Configure flow operation.

  help                    Description of the interactive help system

  ip                      Interface Internet Protocol config commands

  isis                    IS-IS commands

  iso-igrp                ISO-IGRP interface subcommands

  keepalive               Enable keepalive

  l2protocol-tunnel       Tunnel Layer2 protocols

  lacp                    LACP interface subcommands

  load-interval           Specify interval for load calculation for an interface

  logging                 Configure logging for interface

  loopback                Configure internal loopback on an interface

  mac                     MAC interface commands

  macro                   Command macro

  max-reserved-bandwidth  Maximum Reservable Bandwidth on an Interface

  mtu                     Set the interface Maximum Transmission Unit (MTU)

  no                      Negate a command or set its defaults

  pagp                    PAgP interface subcommands

  power                   Power configuration

  qos                     QoS configuration

  rmon                    Configure Remote Monitoring on an interface

  service-policy          Configure QoS Service Policy

  shutdown                Shutdown the selected interface

  snmp                    Modify SNMP interface parameters

  spanning-tree           Spanning Tree Subsystem

  speed                   Configure speed operation.

  storm-control           storm configuration

  switchport              Set switching mode characteristics

  timeout                 Define timeout values for this interface

  transmit-interface      Assign a transmit interface to a receive-only interface

  tx-queue                Configure interface transmit queue

  udld                    Configure UDLD enabled or disabled and ignore global UDLD setting

  vlan-range              config vlan

 

 

test(config-if)#spe

test(config-if)#speed ? 

# 大家可钦点这几个端口的进程,比如那个端口接的是多少个百兆的收发器,我们就足以强制将此端口设置成100M

  10    Force 10 Mbps operation                     # 强制此端口为10M

  100   Force 100 Mbps operation                   # 强制此端口为100M

  1000  Force 1000 Mbps operation                 # 强制此端口为一千M      

  auto  Enable AUTO speed configuration        # 允许速度自动协商

 

test(config-if)#speed 100      

# 通过此命令就可将此端口强制设成100M,私下认可的情况下是auto。

test(config-if)#dup

test(config-if)#duplex ?  # 用此命令可安插此端口的双工情势,有3个选项供接纳。

  auto  Enable AUTO duplex configuration       # 自动配置此端口的双工形式

  full  Force full duplex operation                   # 强制此端口为全双工情势

  half  Force half-duplex operation                  # 强制此端口为半双工方式

 

test(config-if)#duplex auto

test(config-if)#end         # 用end命令可一贯倒退到特权方式,用exit是一层一层的退出。

test#ter

test#terminal moni

test#terminal monitor   

# 展开终端监察和控制。当用telnet登入的时候暗中认可是不呈现各端口的实时变化境况的,张开这几个效应就能够实时的收看那台交流机上哪些端口up,哪个端口down,这对于排错的时候是很有救助的。

test#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

test(config)#int gi1/2     # 重新赶回端口配置格局

test(config-if)#shut        # 此命令可手工业关闭此端口

test(config-if)#no shut   # 此命令为张开此端口

test(config-if)#switchport access vlan ? 

# 那条命令可配备此端口属于哪个vlan,当然此vlan要优先建好。

  <1-4094>  VLAN ID of the VLAN when this port is in access mode

  dynamic   When in access mode, this interfaces VLAN is controlled by VMPS

 

test(config-if)#switchport access vlan 100   

# 我们配备此端口属于vlan100,假设此端口事先属于其它vlan那么,会从其余vlan退出

test(config-if)#exit

test(config)#int rang                    # 亦可成批的铺排端口,利用那几个命令

test(config)#int range gi 1/1 - 5   

# 表示还要对gi1/1到gi1/5那5个端口举行操作,注意命令“1 - 5”,之间有空格。

 

test(config-if-range)#switchport access vlan 100         # 可同时安顿那5个端口属于vlan100

test(config-if-range)#shutdown                                 # 可同不平时候关闭那5个端口

test(config-if-range)#no shutdown                             # 可相同的时候启用那5个端口

test(config-if-range)#exit

test(config-if)#end

test#

test#sh int gi1/2                                                       # 在特权情势中,可查阅单个端口的状态

GigabitEthernet1/2 is down, line protocol is down (notconnect)

# 这行说明此端口当前的状态是down的

  Hardware is GigabitEthernetPort, address is 001a.6db4.a3c1 (bia 001a.6db4.a3c1)   

# 此端口的MAC地址

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, link type is auto, media type is 10/100/1000-TX         

# 此端口的模式为10/100/1000-TX

  input flow-control is off, output flow-control is off

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

test#sh int gi1/1

GigabitEthernet1/1 is up, line protocol is up (connected)   

# 这行表明此端口是up的,并且连有网线。

  Hardware is GigabitEthernetPort, address is 001a.6db4.a3c0 (bia 001a.6db4.a3c0)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX

  input flow-control is off, output flow-control is off

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1293000 bits/sec, 426 packets/sec

  5 minute output rate 2410000 bits/sec, 528 packets/sec

     273591244 packets input, 142285545179 bytes, 0 no buffer

     Received 0 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored       # 没有输入错误,表明链路状态良好

     0 input packets with dribble condition detected

     335026620 packets output, 223732323465 bytes, 0 underruns  # 输出数据包统计

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

test#wr           # 保存刚才的布署结果

 

单击”2960-24TT“,在弹出的对话框,选择”命令行“单击”回车“举办客商命令格局,改模式,只好选用简单的查阅命令

在客商命令情势,输入”enable“,步向”特权情势“

输入”disable“退出特权情势

跻身特权格局下,输入”configure terminal“步向全局配置形式

翻开、检索命令:”show“,

经过show命令查看当前安排意况

show ?协理命令查看当前颇具的查阅命令

show version 查看IOS版本,查看配置新闻,包涵型号、体系号、版本等

show Flash 查看flash内部存款和储蓄器使用情形

show Mac-address-table查看MAC地址表

show interface fa0/1查看端口音讯

本文由明仕msyz手机版发布于情感专区-情绪智力,转载请注明出处:思科交换机基本配置实例讲解,思科模拟器上进

TAG标签:
Ctrl+D 将本页面保存为书签,全面了解最新资讯,方便快捷。